Jump to content

Recommended Posts

Can someone please help me? I am using WordPress to create my site. When you go to my blog and click on the comments link nothing happens. Why? What am I doing wrong?

 

Also, my archives don't work. Any suggestions?

 

I've clicked on and off anything and everything to try and make these work correctly. Nothing happens. I'd appreciate any help.

 

My website is www.MLCBusinessSolutions.com.

 

Thanks,

Share this post


Link to post
Share on other sites

Without being at your admin screen, I'm going to risk over information

 

When you want separate pages, but one to be the blog, in SETTINGS, READING, you can choose on page to be the static 'home' page and the blog page to receive posts.

 

On each page editing or building new, 'way down at the bottom is the option to Allow Comments or Allow Pings, under discussion. Be sure that Allow Comments is selected for the Blog Page. I 'deselect' the Allow Comments for pages that are not blogs. It is something that I have to remember every time I create a new page. I don't know what the theme is that you've chosen, but you want one that empowers you to allow comments or not.

 

Archives may be a widget that you have to set up.

 

HTH

Share this post


Link to post
Share on other sites

I think this is the code for your Archives part:

</table></div></li><li id="archives-2" class="widget widget_archive"><h2 class="widgettitle">Archives</h2> <ul>

<li><a href='http://www.mlcbusinesssolutions.com2009/09' title='September 2009'>September 2009</a></li>

</ul>

</li> </ul>

</div>

 

Shouldn't there be an open <div>?

 

When looking at the source code for your blog page, I can't find anything about a comment area.

 

 

 

 

Share this post


Link to post
Share on other sites

There is a link in the source code under the comments, but there must be something in the admin/theme editor area to see.... difficult to judge from here.

Your Archive link in the sideboard is messed up: there is a slash missing. That's why the link is wrong.

But this as well is only possible to fix from inside the admin area.

Edited by Uli

Share this post


Link to post
Share on other sites

I already have a link for the Archives, but it just does not work when you click on it. I entered the HTML code you gave me in the Editor section and it just gave me another archive link that does not work. So I took it out.

 

Nothing seems to work when you click on the links (comment, archive, tags). I know it's just something simple that I'm missing.

 

Any more ideas?

Share this post


Link to post
Share on other sites

I'm web designer specialized on Wordpress.

So the only thing I can offer you is to add a user with admin rights, send me the login by mail or other and delete the user once I fixed it... or tried at least :)

Share this post


Link to post
Share on other sites

When I click on " No comments" as if to read one if it were there, the status line reads

mlcbusinessolutions.com/blog#response

 

Selecting the categories gets a blank screen that claims it is "done" But, you probably already know that.

Share this post


Link to post
Share on other sites
Guest

It looks to me like a setting in your permalinks. Your links are getting created without a slash in between the domain name and the parameters of the link (this is true of all the links in your blog).

 

Are you using a permalink plugin? If so, please post details. If not, please post your permalink settings.

Share this post


Link to post
Share on other sites

Without seeing the back end, it looks like Leanne is right. If you are in the dashboard, go to Settings>Permalinks on the navigation on the left hand side.

 

If your permalinks are set to anything other than default, scroll down to the bottom of the permalinks page. Does it have a message telling you that you need a mod rewrite and you have to add code to an htaccess file? You have to add that code to the htaccess file in the same directory as your index file is in.

 

If your permalinks are set to default, try switching to the Kubrick (default) theme and see if it's still happening. That will rule out a problem in the code of the theme.

 

 

Share this post


Link to post
Share on other sites

I want to thank you all for all the help that you have given me.

 

I found my problem. Which, of course, leads me to another question. LOL

 

First, here was my problem. In the Permalink Settings I had it set to Custom Structure. When I changed it back to default everything started working. However, now my URL's are not what I want them to be. In other words, instead of showing http://www.MLCBusinessSolutions.com/About it shows http://www.mlcbusinesssolutions.com/?page_id=2. How do I fix this?

 

Thanks,

Share this post


Link to post
Share on other sites
I want to thank you all for all the help that you have given me.

 

I found my problem. Which, of course, leads me to another question. LOL

 

First, here was my problem. In the Permalink Settings I had it set to Custom Structure. When I changed it back to default everything started working. However, now my URL's are not what I want them to be. In other words, instead of showing http://www.MLCBusinessSolutions.com/About it shows http://www.mlcbusinesssolutions.com/?page_id=2. How do I fix this?

 

Thanks,

 

YAY!! Glad you got it fixed.

 

 

When I put /%postname%/ into the custom structure, it works.

 

On another one I have /%year%/%monthnum%/%postname%/ This is mostly a blog. The pages have the name I want; the posts have the name & the year/month.

Share this post


Link to post
Share on other sites

Go to the permalink settings, activate "custom" and enter: /%postname%.htm

(don't forget the slash) and save it... Done :mellow:

Edited by Uli

Share this post


Link to post
Share on other sites

You guys are great! I got it figured out thanks to all your help. I really appreciate it.

 

Since you all are so good I was wondering if you could answer me one more question?

 

I switched web hosts and I need to transfer one of my sites to the new host. I know how transfer the domain name but how do I transfer all pages without having to create them from scratch again?

 

Thanks,

Share this post


Link to post
Share on other sites

I just did a re-publish which took everything to the new spot. I used my web building software. All of the wordpress stuff went fine. I moved several sites at once.

 

If you are using FTP, it shouldn't be difficult, but I have no experience about how to do it. Rebuilding shouldn't be the answer.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Want to Become a VA?
    Invest in The VAC!
    How Do YOU Startup A

    Virtual Assistant Organization Association
    Upgrade Your FREE Account & Receive Today...
    * Access to Our Bus JOB Board *
    * Group Coaching & Training*
    *Training Tracks*
    * Private Mastermind Area *
    * Business Templates *
    * Contracts & Forms*
    * Plus VAinsider Perks! *
    UPGRADE HERE


    Virtual Assistant Organization Association

    Virtual Assistant Organization Association











×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.